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This two-part data recipe is for users who wish to map regional inundation with 
spaceborne L-band synthetic aperture radar (SAR). Users will create 

a) Colorized inundation map 
b) Inundation animation 

 
In this document you will find: 

A. Background 
B. Materials List 1 
C. Steps for Generating Inundation Animation 
D. Sample Inundation Animation 
E. Sample Granules 
F. Materials List 2 
G. Steps for Generating Colorized Inundation Map 
H. Sample Colorized Map 

 
A) Background 
The all-weather ability of synthetic aperture radar (SAR) to penetrate cloud cover 
and low-light conditions to acquire imagery of the Earth’s surface is well known. 
Given the recent availability of high-resolution terrain models at 30 meters from 
the Shuttle Radar Topography Mission (SRTM) and an interest to make SAR 
data easier to use, the Alaska Satellite Facility (ASF) now offers radiometric 
terrain corrected (RTC) L-band image products from ALOS PALSAR data. At 
longer wavelengths such as L-band, SAR can penetrate surface vegetation 
including the Amazon rain forest, and flooding events can be mapped very 
accurately at high resolution. With the availability of RTC data, it is now relatively 
easy to do accurate flood mapping using PALSAR data. In this recipe, we 
describe methods used to (a) create an inundation image animation from 16 
PALSAR RTC products and (b) produce an inundation map that quantifies the 
number of flooding events from the given set of data. 
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B) Materials for generating inundation animation 

 ALOS-1 PALSAR RTC products 

o For this exercise, you may use the sample granules in Section E 
 ArcMap (version 10.3 used in this recipe) 

Adobe Photoshop (CS6 used in this recipe) 
 

C) PART 1: Processing steps to generate inundation animation 
 

Download and Organize Data 
1. Download data either by clicking the links to the sample data below in Part 

E or by bulk downloading using the Vertex data portal.  
a) For help using Vertex to search for and download data, please refer to 

the Vertex Getting Started User Guide 
2. Organize data 

a) Extract data from the downloaded .zip files and copy the HH image 
from each granule into a single HH frame folder 

 

Convert Images to decibels 
 

1. Convert the RTC images from linear power to db 
a) In ArcMap, load all of the RTC HH GeoTIFF images from the folder. If 

prompted to create pyramids for an image layer, click <No> 
b) Start the Raster Calculator tool (Spatial Analysis Tools > Map Algebra) 

Note: Raster Calculator is part of the Spatial Analyst toolbox, 
which requires the Spatial Analyst license 

c) Create output folder HH_db, and specify output filename as 
Rnnnnn_db.tif where nnnnn is orbit number. 

d) Compute db = 10. * Log10 (“RTC_HH_granule”)  (Figure 1) 
e) Repeat process for all RTC granules. 

http://www.alaska.edu/nondiscrimination
http://desktop.arcgis.com/en/arcmap/
https://www.adobe.com/
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Figure 1: Raster Calculator set-up for one sample granule 
 

 
Process and Classify Images 

 

1. Filter Images to reduce speckle 
a) In the ArcMap top menu, go to 

Windows > Image Analysis 
b) Select the first image. 
c) Under “Processing,” click on ”Add 

Function” (Figure 2). 
d) In the “Function Template Editor,” 

right-click on “Identity Function,” 
mouse-over “Insert Function,” and 
select “Speckle Function” from the 
menu. 

e) In the parameters menu that 
appears, change the “Filter Type” 
setting from “Lee” to “Enhanced Lee” 
and keep the rest of the parameters 
set to their defaults. 

f) The files that result from this are 
temporary. To save them 
permanently to the hard drive as a 
GeoTIFF, use the Copy Raster (Data 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 2: Location of the Add 
Function tool in the Image Analysis 
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Management Tools > Raster > Raster Dataset) tool, with the Output Raster 
Dataset field set to a directory and filename (ending in .tif) of your choice, and all 
other fields blank. 

g) Repeat Steps b through f for all images. 

2. Require calculation of statistics 
a) In ArcMap, display all filtered db images created by the Copy Raster tool. 
b) Open Batch Calculate Statistics (Data Management Tools > Raster > Raster 

Properties). 
c) Drag and drop all images in to the input and click OK to calculate statistics for 

all of the images. 
 
3. Display images 

a) Right-click on a feature layer and select Properties. Then click on the 
<Symbology> tab. Under “Show:” select “Classified.” Then, under “Classification,” 
set Classes to “2.” 

b) Click the <Classify> button, and a histogram will display. 
c) By default, “Classification  Method” is “Natural Breaks (Jenks).” Two  vertical blue 

lines appear on the graph, and you should notice a small peak and a large peak 
indicating a bimodal distribution. 

d) Set “Classification Method” to “Manual,” and specify a starting break point, such 
as “-14.” Click <OK> (Figure 3). 

e) Under “Color Ramp,” double click on the first class Color box and select a blue 
color. 

f) Double click on the second class Color box, select black, and click 
<OK>. The feature layer will be displayed with open water as blue and land as black. 
Notes: The values for the break points can change significantly between locations 
and datasets, and will generally require several iterations to determine. 

 
4. Refine the breakpoint value until water is mostly contained within river channels, and 

very small number of blue dots show on land outside river channels. 
a) Right-click the image layer, and select “Properties.” 
b) Click on the <Symbology> tab; then click on “Classify…” 
c) Change the value of the breakpoint, increasing it by one each time (so “-13” is the 

first increased value). 
d) Click <OK>. 
e) Again specify the two colors for the two classes as blue and black; then click 

<OK> 
 

Notes: We found “-11” to be the best value for minimizing water speckle over land. 
 
5. Further refine breakpoint values 

a) Determine a second breakpoint for areas in the image that are brighter due to 
double bounce of flooded forests. Here you will determine a breakpoint on the other 
side of the large peak. 

b) Start with a higher value such as “0.” 
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c) Set the first class color box to black and the second class color box to yellow, for 
values greater than the breakpoint. Look for yellow in the image and notice how 
much speckle noise you have away from the bright feature areas. 

d) Decrease the breakpoint value by one until the amount of speckle is close to what 
was observed for the blue class. 

 

Notes: We found “-4” to be a good value for the second class 
 
e) Select number of classes to be “3,” and enter both breakpoint values. Set the first 

class Color to blue, second class Color to black, and third class Color to yellow. 
You should see the image classified with water channels as blue and double 
bounce areas as yellow. 

 

Notes: We found it useful to pick a minimum flood and maximum flood image to verify 
that the breakpoints work as desired. Some knowledge of  the extent of seasonal 
flooding is useful to confirm that the results are correct. 

 

 
 

Figure 3: Final results of steps a-e with the suggested breaks. 
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6. Save a colorized raster dataset for each classified image for creating an  animation. 
a) Use the Apply Symbology From Layer tool (Data Management Tools > Layers and 

Tables Views) to set the symbology of the remaining greyscale images, with the 
“Symbology Layer” field set to any correctly colored image. 

b) When each image is colored correctly, right click on the image and select “Data 
-> Export Data...” This will display the “Export Raster Data” window. 

c) Set “Extent” to “Data Frame (Current).” 
d) Set “Output Raster” to “Use Renderer” and “Force RGB.” 
e) Specify an output directory by clicking the folder button; then browse to the desired 

output directory. 
f) In the “Name:” field, specify the output filename, such as 

class_xxxxx_db.tif, and  “Format:” “TIFF. 
g) Click the <Save> button. 

 
 
 

 

 
 

Generate and View Animated GIF 
 
1. Generate animated GIF to show the sequence of classified images showing 

inundation 
a. Open Adobe Photoshop 
b. Select “File -> Scripts -> Load Files into Stack…” to load the color classified 

imagery. 
c. Use the <Browse> button to navigate to the directory you used for the 

“Export_Data” step in ArcMap (step 6). Select all input files. The data files will 
load in the layers control panel. 

d. Once the data are all loaded, click on the Create Frame Animation button in the 
<Timeline> tap section located below the image. This  will create a single frame 
instance. 

e. In the bottom right corner of the image display window, click on the menu button 
that looks like an arrowhead next to four horizontal lines. A timeline menu is 
displayed (Figure 4). 

f. In the timeline menu, select “Make Frames From Layers” to populate the 
timeline with all image frames. The frames are numbered 1 through 16. There is 
a delay setting below each frame. 

g. 
Notes: It is preferred to set the delay to increments of 0.5 seconds per cycle of 
PALSAR data. Each cycle is 671 orbits; if there are gaps in the temporal 
coverage, then a longer delay can be set as a multiple of 0.5 seconds. In our 
case, we set delays of 0.5, 0.5, 1.5, 1.0, 0.5, 0.5, 0.5, 1.5, 2.0, 0.5 1.5, 1.0 0.5, 
0.5, and 0.5 

respectively. The delay of 1.0 was when one cycle was skipped, 1.5 
for when two cycles were skipped, etc. 
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Figure 4: Location of the timeline menu (red arrow) and “Make Frames From Layer” (blue arrow) in 
Photoshop 

 
 

 

h. Click on the “0 sec.” dropdown menu under each frame, which 
offers a choice of delay settings. If the specific delay you want is 
not listed, select  “Other” and enter the delay. 

i. If you want the animation to loop more than once, click on the 
<Once> button located below the timeline images and select “3 
times,” for example . 

j. To save this animation, select “File -> Save For Web.” 
 

Notes: A warning may be displayed due to the size of the images; 
click yes if it does. In the image size section, type 15% to reduce 
the image size of the output. 

 
k. Click the <Save> button, specify the output filename, and click save 

again to save the animated GIF image. 
 

2. Using your file browser, navigate to the output directory containing 
animated GIF. Double click on file to execute. Your animation should be 
displayed. 
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D) Output Example of Inundation Animation 
 
Click the following link to see the resulting gif in your browser: 
https://www-dev.asf.alaska.edu/data-tools/data-recipes/how-to-map-inundation/ 

 

 

 
Figure 5: Frame from animation of inundation in Amazon rain forest. Credit: Chapman, Guritz 
2016; RTC: ASF 2015; Includes Material © JAXA/METI 2007. 

http://www.alaska.edu/nondiscrimination
https://www-dev.asf.alaska.edu/data-tools/data-recipes/how-to-map-inundation/
https://www.asf.alaska.edu/data-tools/data-recipes/how-to-map-inundation/
https://www.asf.alaska.edu/data-tools/data-recipes/how-to-map-inundation/
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E) Links to Sample RTC Products 

Click on product names to download each granule individually, or copy the list of 
granule names and paste them in Vertex to bulk download them. See Part One 
for more detailed instructions on using Vertex. 

 
 
 

Granule Name Product Name 

ALPSRP048877090 AP_04887_FBS_F7090_RT1.zip 

ALPSRP075717090 AP_07571_FBD_F7090_RT1.zip 

ALPSRP082427090 AP_08242_FBD_F7090_RT1.zip 

ALPSRP102557090 AP_10255_FBS_F7090_RT1.zip 

ALPSRP115977090 AP_11597_FBS_F7090_RT1.zip 

ALPSRP122687090 AP_12268_FBD_F7090_RT1.zip 

ALPSRP129397090 AP_12939_FBD_F7090_RT1.zip 

ALPSRP136107090 AP_13610_FBD_F7090_RT1.zip 

ALPSRP156237090 AP_15623_FBS_F7090_RT1.zip 

ALPSRP183077090 AP_18307_FBD_F7090_RT1.zip 

ALPSRP189787090 AP_18978_FBD_F7090_RT1.zip 

ALPSRP209917090 AP_20991_FBS_F7090_RT1.zip 

ALPSRP223337090 AP_22333_FBS_F7090_RT1.zip 

ALPSRP230047090 AP_23004_FBD_F7090_RT1.zip 

ALPSRP236757090 AP_23675_FBD_F7090_RT1.zip 

ALPSRP243467090 AP_24346_FBD_F7090_RT1.zip 

ALPSRP263597090 AP_26359_FBS_F7090_RT1.zip 

ALPSRP270307090 AP_27030_FBS_F7090_RT1.zip 

http://www.alaska.edu/nondiscrimination
https://search.asf.alaska.edu/
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_04887_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_07571_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_08242_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_10255_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_11597_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_12268_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_12939_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_13610_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_15623_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_18307_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_18978_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_20991_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_22333_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_23004_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_23675_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_24346_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_26359_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_27030_FBS_F7090_RT1.zip
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F) Materials List to Generate a Colorized Inundation Map 
 

 ArcMap 

 lee filtered db images from generating an inundation animation (see 
above) 

 

G) PART 2: Processing Steps to Generate a Colorized Inundation Map 
 
 
Classify Images 

 

1. Classify each image to water (1) or land (0) 
a) In ArcMap, load each of the lee filtered db images. Then Reclassify the 

floating point data of each image, mapping all water areas to 1 and all 
non-water areas to 0. Select the Input Raster as one of the displayed 
images. This will populate the reclass table. There are nine data 
ranges, plus NoDATA. First, select ranges 2 through 7, and delete 
them. Then change the remaining (Figure 6) 

 

i. Old Values: New Value: 
ii. -29.082478 - -11.0 1 
iii. -11.0 - -4.0 0 
iv. -4.0 – 15.578245 1 
v. NoData 0 

 

 
 

Figure 6: Reclassify set-up in ArcGIS for one sample 
granule, shows i-v above. 

http://www.alaska.edu/nondiscrimination
http://desktop.arcgis.com/en/arcmap/
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b) Also specify the output filename and check the box to set data outside 
data range to NoData. The result should be an image with two values: 
0 and 1. 

 

Notes: Values in this table can be tricky; once you have set all new 
values, click on an unchanged value to ensure that all values are 
entered. 

 
c) Repeat this for all images. Then right click on each input image, and 

select remove to leave just the classified images. 
 
 
Create the Final Product 

 
1. Add up all these images. 

a) Bring up Raster Calculator, and notice the list of images on the left. 
b) In the equation box, type in count = 
c) Double click on the first image name; then click on the + button. 
d) Continue adding filenames with the symbol + between each until all 

image names are used. 
e) Specify the path and filename of the output raster you will create. 
f) Click the ok button to execute the command. 

 

Notes: The combined image will display with random colors assigned. 
It is a good idea to set the color for 0 and 1 to black. Usually values of 
one are due to remaining speckle in the data after filtering. You can 
change colors by right-clicking on a color in the layers panel, which 
brings up a matrix of standard colors. Select colors that are easily 
distinguished and in some logical order. 

 
g) When you are happy with the color settings, right click on the filename 

and select Data/Export Data. An export raster data panel will display. 
h) Set Data Frame (current) for Extent. 
i) Click check box for Use Renderer, and Force RGB. 
j) Specify an output directory, click the folder button, and browse to the 

output directory for this classified image. 
k) Also specify the output filename, such as overlap_count.tif, and format: 

TIFF. 
l) Click the save button. 

 

Notes: This creates a full resolution image of inundation. You should also 
use the snipping tool to grab a low-resolution version of the overlap count 
image and the color key to be used with either image. 

http://www.alaska.edu/nondiscrimination
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H) Output Example of Colorized Inundation Map 
 

 

 
 
 
 
Figure 7: Map of inundation in Amazon rain forest. The color key provides the color for the 
number of times an area was flooded in 16 granules, and 16 (pink) represents constant river. 
Numbers less than 16 are the number of times an area floods. 
Credit: Chapman, Guritz 2016; RTC: ASF 2015; Includes Material © JAXA/METI 2007. 
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