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This two-part data recipe is for users who wish to map regional inundation with 

spaceborne L-band synthetic aperture radar (SAR). Users will create: 

a) Inundation animation 

b) Colorized inundation map 

In this document you will find 

A. Background 

B. Materials List for Generating Animation 

C. Sample Granule List 

D. Steps for Generating Inundation Animation 

E. Sample Inundation Animation 

F. Materials List for Generating Colorized Map 

G. Steps for Generating Colorized Inundation Map 

H. Sample Colorized Inundation Maps 

I. How to Access Orfeo Toolbox (Windows) 

A) Background 

The all-weather ability of synthetic aperture radar (SAR) to penetrate cloud cover and 

low-light conditions to acquire imagery of the Earth’s surface is well known. Given the 

availability of high-resolution terrain models at 30 meters from the Shuttle Radar 

Topography Mission (SRTM) and an interest to make SAR data easier to use, the 

Alaska Satellite Facility (ASF) offers radiometric terrain corrected (RTC) L-band image 

products from ALOS PALSAR data. 
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At longer wavelengths such as L-band, SAR can penetrate surface vegetation including 

the Amazon rain forest, and flooding events can be mapped very accurately at high 

resolution. With the availability of RTC data, it is now relatively easy to do accurate flood 

mapping using PALSAR data. In this recipe, we describe methods used to (a) create an 

inundation image animation from 18 PALSAR RTC products and (b) produce an 

inundation map that quantifies the number of flooding events from the given set of data. 

 

B) Materials List for Generating Animation 

 Windows, Mac OS X 

 ALOS-1 Palsar RTC products 

• For this tutorial you may use the sample granule list below, or download 
your own RTC products using Vertex 

• For help using Vertex, refer to the Vertex Getting Started User Guide 

 QGIS (version 2.18.12 used in this recipe) with Orfeo Toolbox (Windows users 
see Section I) 

 GIMP (version 2.8 used in this recipe) 
  

http://www.alaska.edu/nondiscrimination
https://www.asf.alaska.edu/other-data/vertex-getting-started-user-guide/
https://qgis.org/en/site/
https://www.gimp.org/
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C) Sample Granule List 

Click on the product names to download each granule individually 
 

 

Granule Name 
 

Product Name 

 

ALPSRP048877090 
 

AP_04887_FBS_F7090_RT1.zip 

 

ALPSRP075717090 
 

AP_07571_FBD_F7090_RT1.zip 

 

ALPSRP082427090 
 

AP_08242_FBD_F7090_RT1.zip 

 

ALPSRP102557090 
 

AP_10255_FBS_F7090_RT1.zip 

 

ALPSRP115977090 
 

AP_11597_FBS_F7090_RT1.zip 

 

ALPSRP122687090 
 

AP_12268_FBD_F7090_RT1.zip 

 

ALPSRP129397090 
 

AP_12939_FBD_F7090_RT1.zip 

 

ALPSRP136107090 
 

AP_13610_FBD_F7090_RT1.zip 

 

ALPSRP156237090 
 

AP_15623_FBS_F7090_RT1.zip 

 

ALPSRP183077090 
 

AP_18307_FBD_F7090_RT1.zip 

 

ALPSRP189787090 
 

AP_18978_FBD_F7090_RT1.zip 

 

ALPSRP209917090 
 

AP_20991_FBS_F7090_RT1.zip 

 

ALPSRP223337090 
 

AP_22333_FBS_F7090_RT1.zip 

 

ALPSRP230047090 
 

AP_23004_FBD_F7090_RT1.zip 

 

ALPSRP236757090 
 

AP_23675_FBD_F7090_RT1.zip 

 

ALPSRP243467090 
 

AP_24346_FBD_F7090_RT1.zip 

 

ALPSRP263597090 
 

AP_26359_FBS_F7090_RT1.zip 

 

ALPSRP270307090 
 

AP_27030_FBS_F7090_RT1.zip 
 

 
 

  

http://www.alaska.edu/nondiscrimination
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https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_10255_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_11597_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_12268_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_12939_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_13610_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_15623_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_18307_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_18978_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_20991_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_22333_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_23004_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_23675_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_24346_FBD_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_26359_FBS_F7090_RT1.zip
https://datapool.asf.alaska.edu/RTC_HI_RES/A3/AP_27030_FBS_F7090_RT1.zip
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D) Part 1: Steps for Generating Inundation Animation 

Step 1: Download and Organize the Data 

1. Download the granules from Section C 

2. Extract data from the downloaded .zip files and copy the HH image from each 

granule into a new folder (e.g., HH) 

Step 2: Convert Images to Decibels in QGIS 

1. Create a new directory to place your output images (e.g., db_HH) 

2. Open QGIS and use the Open Raster  button to load the HH images from the 

folder you created in Step 1 

3. Ensure that your HH images are open in the Layers Panel (there should be 18 of 

them) 

4. Ensure that your Processing Toolbox is open and ready (Processing 

menu>Toolbox) 

5. Within the Processing Toolbox search for “raster calculator” 

http://www.alaska.edu/nondiscrimination
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6. Right-click on  (GDAL) and execute as batch process (Figure 1) 
 
 

 

Figure 1: GDAL Raster Calculator with batch processing 
 

7. In the Parameters tab, click on “…” next to the first box within “Input Layer A” 

8. Select from open layers and click “Select All” 

9. Click OK to add all image layers to Input Layer A 

10. Drag the navigation bar over until you see “Calculation in gdalnumeric 
syntax…” 

11. In the first box, enter “10*log10(A)” 

12. Double-click on the title above where you just entered your formula 

13. To the right of the “Calculation” header, find “Output raster type” 

14. Under Output raster type, change the selection from Byte to Float32 

15. Double-click on “Output raster type “ to apply to all 

16. To the right of Output raster type, find “Calculated” 

17. Click on “…” next to the first box within “Calculated” 

18. Navigate to the directory/folder you created and enter “db_” and click Save 

19. When prompted select “Fill with parameter values” and click OK 

20. To the right of “Calculated” find “Load in QGIS” 

21. Change the first “Yes” to “No” and double-click on “Load in QGIS” 

22. Click Run to begin batch processing 

23. Close Batch Processing dialog window once complete 

24. Close all images in QGIS using the Layers Panel close button  
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Step 3: Apply Despeckling to dB Converted Images 

1. Create a new directory to place your output images (e.g., sf_db_HH) 

2. In QGIS, use the Open Raster  button to load the decibel-converted 

images you created in Step 2 

3. Within the Processing Toolbox, search for “Despeckle” 

4. Right-click on  (Orfeo) and execute as batch process (Figure 2) 
 

 

Figure 2: Despeckle (lee) tool with batch processing 
 

5. Under “Input Image”, click the “…” and select from open Layers 

6. Click “Select All” and click OK to add all images 

7. Scroll right until you find “Output Image” and select “…” 

8. Navigate to the directory/folder you created and enter “sf_” and click Save 

9. When prompted select “Fill with parameter values” and click OK 

10. To the right of “Fill with parameters values” find “Load in QGIS” 

11. Select “No” and double-click on “Load in QGIS” to apply to all 

12. Click Run to begin batch processing 

13. Close Batch Processing dialog window once complete 

14. Close all images in QGIS using the Layers Panel close button  

Step 4: Exclude Erroneous Pixels at the Edge of Your Images 

The Despeckle tool leaves a strip of extra pixels with very negative values to the 

edge of the images, which must be removed before the following analysis. When 

you open the despeckle images you will find that the images are not correctly 

rendering due to these negative values. 
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1. Create a new directory to place your output images (e.g., xsf_db_HH) 

2. In QGIS, use the Open Raster  button to load the images created in Step 3 

3. Within the Processing Toolbox search for “raster calculator” 

4. Right-click on  (GDAL) and execute as batch process 

5. In the Parameters tab click on “…” next to the first box within “Input Layer A” 

6. Select from open layers and click “Select All” 

7. Click OK to add all image layers to Input Layer A 

8. Drag the window bar over until you see “Calculation in gdalnumeric syntax…” 

9. In the first box (Figure 3), enter “(A>-9999)*A” 
 

 

Figure 3: Raster Calculator with batch processing showing correct formula 
 

10. Double click on ““Calculation in gdalnumeric syntax…” to apply to all 

11. To the right of “Calculation”, find “Set output nodata value” 

12. Enter “0” in the first box and double-click on “Set output nodata value” 

13. To the right of the “Calculation”, find “Output raster type” 

14. Under “Output raster type”, change the selection from Byte to Float32 

15. Double-click on “Output raster type” to apply to all 

16. To the right of “Output raster type”, find “Calculated” 

17. Click on “…” next to the first box within “Calculated” 

18. Navigate to the directory/folder you created and enter “x” and click Save 

19. When prompted select “Fill with parameter values” and click OK 

20. To the right of “Calculated” find “Load in QGIS” 

21. Change the first “Yes” to “No” and double-click on “Load in QGIS” 

22. Click Run to begin batch processing 

23. Close Batch Processing dialog window once complete 

24. Close all images in QGIS using the Layers Panel close button  

http://www.alaska.edu/nondiscrimination


7 December 2018 v.3 |8 

UAF is an AA/EO employer and educational institution and prohibits illegal discrimination against any individual: 
www.alaska.edu/nondiscrimination 

 

Step 5: Classify the Images using a Threshold 

This step assumes that your images have a bimodal distribution of pixel values in the 

image. If you are using different data, the class values will vary and it may take 

several iterations to determine the appropriate thresholds. For the process of 

determining the appropriate thresholds, it is good practice to consider one image 

representing the maximum flooding and another image representing minimum 

flooding. Knowledge of the geographical coverage of seasonal flooding helps 

confirm whether the results are correct. 

1. In QGIS, use the Open Raster  button to load the images created in Step 4 

2. Right-click on the first image in the Layers Panel and choose “Properties” 

3. In the Style menu change the Render type to “Singleband pseudocolor” 

4. Click on the Histogram tab from the Layer Properties window you have open 

5. View the histogram to interpret the distribute of pixel values in the image 

Note: You should see a clearly bi-modal histogram (Figure 4) with water 

pixels appearing significantly darker than the main image data 

6. To separate water from the rest of the image, pick a threshold at (or near) 

the minimum between the two modes of the distribution (e,g., -13) 
 

 

Figure 4: Histogram showing bimodal distribution of pixel values 
 
 

7. Return to the Style tab of the Layer Properties window and change 

the Interpolation to “Discrete” (Figure 5) 

8. Next to “Classify” click on  three times to add your class value 

http://www.alaska.edu/nondiscrimination
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9. Change the value of the classes to the following: “-13”;”-2”;”inf” 

10. Double-click on the Color to change the class colors 

11. Set “-13” to blue to represent the main channels of water. Refine the breakpoint 

values until water is mostly contained within river channels and a very small 

number of blue dots show on land outside river channels. 

12. Set “-2” to black to represent land 

13. Set “inf” to yellow to represent brighter areas because of double-bounce, which 

indicates flooded vegetation. To increase the prominence of double-bounce, you 

must adjust “-2” to a lower value, which adjusts the breakpoint of your second 

threshold value. 

 

 

Figure 5: Classification of the image with determined thresholds 
 

 
14. Adjust the following values until you are satisfied. The class values will be 

determined by the pixel values in the image. 

15. Optional: You may adjust Resampling in the Style menu to smooth rendered 

pixels 

16. Apply the same Style properties to all images by right-clicking on the image with 

the desired classification and select “Styles>Copy Style” 

17. Click the button in the Layers Panel to collapse all layers and select all other 

layers (using Shift) 
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18. Right-click on any of the selected images and click on “Paste Style” 

Step 6: Export Classified Images as PNG Image Files 

1. Create a new directory to save your exported images (e.g., Flood_PNG) 

2. In QGIS, ensure that all of your images are still open in the Layers Panel 

3. After applying the correct thresholds and colors to all images, turn off visibility 

of all layers except the first one (xsf_db_AP_27030_FBS_F7090_RT1_HH) 

by clicking on the checkbox next to the raster layer’s name 

4. Use in the Map Navigation toolbar to center your image to prepare for 

PNG exporting (Figure 6) 
 

 

Figure 6: All of the images with the same symbology 
 

5. Navigate to Project > Save as Image… 

Tip: These steps can be cumbersome if you manually type in each file name. 

To speed up the process, right-click on each image and select “Rename”. Once 

highlighted you can copy the name of the file before saving your image and 

simply paste the file name in box, then add a “.png” file extension 

6. Save the as “xsf_db_AP_27030_FBS_F7090_RT1_HH.png” and click OK 

7. Turn off the first image and select the next image 

8. Repeat Steps 1-5 for all images until you have 18 PNG image files 

9.  
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Step 7: Generate and Display Animated GIF with GIMP 

1. Select or create a directory to save your animated GIF file 

2. Open GIMP 2 and select “File > Open as Layers…” 

3. Navigate to the directory where your image files are located and select all 

4. Once all images are loaded, select “File > Export As…” 

5. Select the directory you chose to save your animation and save the animation as 

“Flood_Animation.gif” and an Export GIF dialog window will appear (Figure 7) 

 

Figure 7: GIMP Export Image as GIF dialog 
 

6. Check the “As animation” box and set “Delay between frames” to “500” 

7. Check “Use delay entered above for all frames” and click “Export” 

8. Navigate to the “Flood_Animation.gif” file and open the animation in a browser by 

using right-click “Open as ” 
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E) Sample Inundation Animation 

Click on the following link to see the resulting gif:  

https://media.asf.alaska.edu/uploads/Data%20Recipes/palsar_inundation_bigger.gif 

 

Figure 8: Frame from animation of inundation in Amazon rain forest. Credit: 

Chapman, Guritz 2016; RTC: ASF 2015; Includes Material © JAXA/METI 2007. 

http://www.alaska.edu/nondiscrimination
https://media.asf.alaska.edu/uploads/Data%20Recipes/palsar_inundation_bigger.gif


7 December 2018 v.3 |12 

UAF is an AA/EO employer and educational institution and prohibits illegal discrimination against any individual: 
www.alaska.edu/nondiscrimination 

 

F) Materials List for Generating Colorized Map 

 Filtered PALSAR images that were previously generated in Step 4 of Part 1 

 QGIS 2.18.12 
 
 

G) Part 2: Steps for Generating Colorized Inundation Map 

Step 1: Classify the Images Using a Threshold In QGIS 

Classify each image to separate water (1) from land (0). 

1. Create a new directory to save your output files (e.g., Reclass_HH) 

2. In QGIS, use the Open Raster  button to load the images created in Step 4 

(e.g., xsf_db_AP_10255_FBS_F7090_RT1_HH) 

3. Within the Processing Toolbox search for “reclassify” 

4. Right-click on  (SAGA) and run as batch process (Figure 9) 
 

 

Figure 9: Reclassify values (simple) with batch processing 
 

5. Click on “…” next to the first box within “Grid” 

6. Select from open layers and click “Select All” 

7. Click OK to add all image layers to Grid 

8. To the right of “Grid” find “Replace Condition” 

9. Change the condition to “(1) Low value < grid value < high value” 

10. Double-click on “Replace Condition” to apply to all 

http://www.alaska.edu/nondiscrimination
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11. To the right of “Replace Condition” find “Lookup Table” 

12. Click on “…” to the right of the first box within Lookup Table 

13. In the Fixed table window assign the following values seen in Figure 10 below 
 

 Low Value  High Value  Replace with 
1 -30 -11 1  
2 -11 -4  0  
3 -4 15 1  

 
 

Figure 10: Table to reclassify the values 
 

15. Repeat for all images (batch process won’t allow to apply to all) 

16. To the right of “Lookup Table” find “Changed Grid” 

17. Click on “…” next to the first box within “Changed Grid” 

18. Navigate to the directory you created and enter “r_” and click Save 

19. When prompted, fill with parameter values and click OK 

20. To the right of “Changed Grid” find “Load in QGIS” 

21. Change the first option to “No” and double-click “Load in QGIS” to apply to all 

25. Click Run to begin batch processing 

26. Close Batch Processing dialog window once complete 

22. Close all images in QGIS using the Layers Panel close button  

Step 2: Create the Final Product 

1. Choose a directory to save your colorized inundation map 

2. In QGIS, use the Open Raster  button to load your reclassified images created 

in Step 1 of Part 2 

3. Open the Raster Calculator by navigating to Raster > Raster Calculator 

4. Double-click on the first image and click on the “+” operator (Figure 11) 

5. Continue adding each image and symbol until all images are in the equation 
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Figure 11: Raster Calculator with correct setup 
 

6. Set the Output Layer to a name and directory of your choosing (e.g., count.tif) 

7. Click OK to run the Raster Calculator 

Note: the combined image will display as range of gray values. To 

change this, you may classify the pixel values of the image for 

analysis. It is good to assign values 0 and 1 to black because these 

values are usually a result of speckling that remained after filtering. It 

helps to choose colors that are distinguishable and have logic in terms 

of the combined image (higher values indicate more frequent flooding). 

8. Right-click on the image and click on Properties 

9. In the Style tab change render type to “singleband pseudocolor” 

10. Under Color options, select a color ramp from the list or choose random colors 

11. Change classification method to “Equal Interval” 

12. Change the number of classes to “19” 

13. Optional: adjust resampling type to smooth the rendered image 

14. When you are satisfied  click Okay to see the results (Figure 12) 
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H) Sample Colorized Inundation Maps 
 

 

 
 

 
Figure 12: Map of inundation in Amazon rain forest. The color key provides the color for the number of 

times an area was flooded, and 18 represents constant river. Numbers less than 18 are the number of 

times an area floods. Credit: Anderson 2017; RTC: ASF 2015; Includes Material © JAXA/METI 2007 
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I) How to Access Orfeo Toolbox (Windows) 

To use the despeckle tool you must have access to the Orfeo Toolbox, which 

is not included with the Windows standalone version of QGIS 2.18.12. To add 

the toolbox to you must download the toolbox using the OSGeo4W installer. 

Note: For these steps to work properly, you must have QGIS pre-installed. 

1. Navigate to QGIS.org 

2. Select “Download Now” 

3. Under Advanced Users download 

OSGeo4W (64 bit) 

4. Open OSGeo4W setup (Fig. 13) 

5. From the dialog window select 

Advanced Install and click Next > 

6. Select Install from Internet and click 

Next > 

7. Select Root Install Directory (e.g., 

C:\OSGeo4W) and click Next > 

8. Select Local Package Directory 

(default works fine) and click Next > 

9. Select Direct Connection and click 

Next > 

10. Click on ‘http://download.osgeo.org’ to 

select and click Next > 

11. In Select Packages menu type in “otb” in the search box 

12. Click on “Libs” to expand 

13. Under “Libs” click on each “Skip” once and click Next > 

14. Leave all defaults and Click Next > 

15. Click on the checkbox and click Next > 

16. Your download will begin 

17. Click finish once installation completes 

18. Open QGIS 2.18.12 

19. Select ‘Processing’ from the main menu bar 

20. Click on ‘Options…’ 

Figure 13: OSGeo4W Setup 

http://www.alaska.edu/nondiscrimination
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21. Click on ‘Providers’ to expand (Figure 14) 
 

 
Figure 14: Processing Options: Providers 

 
22. Click on ‘GRASS commands’ to expand 

23. Double-click in blank space to the right of “Msys folder” 

24. Delete the existing path for “Msys folder” 

25. Click on ‘Orfeo Toolbox’ to expand 

26. Ensure ‘Activate’ is checked 

27. Double-click in blank space to the right of “OTB applications folder” 

28. Enter the path of your OTB applications folder in the box 

(e.g., “C:\OSGeo4W\apps\orfeotoolbox\applications”) 

29. Double-click in blank space to the right of “OTB command line tools folder” 

30. Enter the path of the OSGeo4W64 bin folder in the box 

(e.g.,“C:\OSGeo4W64\bin”) 

31. Exit QGIS and restart the application 

32. In the Toolbox menu on the right the Orfeo Toolbox will now appear 

33. Click here to return to Section B 
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