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Generating a Radiometrically Terrain Corrected (RTC) Image 
using the Sentinel-1 Toolbox (S1TBX) 

This data recipe is for users who wish to generate an RTC image from Sentinel-1 data 

using easy-to-follow instructions in a graphical user interface (GUI). 
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A) Background 

Distortions in SAR imagery are induced by the side-looking nature of SAR sensors and 

are compounded by rugged terrain. Terrain correction corrects geometric distortions 

that lead to geolocation errors by moving image pixels into the proper spatial 

relationship with each other based on a Digital Elevation Model (DEM). Radiometric 

correction removes the misleading influence of topography on backscatter values. 

Radiometric Terrain Correction (RTC) combines both corrections to produce a superior 

product for science applications. 
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B) Materials List 

1. Sentinel-1 Toolbox (S1TBX) 

S1TBX is integrated in ESA’s Sentinel Application Platform software. 

a. Download the Sentinel Toolboxes installer for your Operating System. 

b. Run the installer and follow the prompts to install the software. 

2. Sentinel-1 data granule 

a. You may download this sample granule, or find a different Sentinel-1 GRD 

granule on ASF’s Vertex data portal. A NASA Earthdata login is required. 

 

C) Preparing Software and Workspace 

1. Open S1TBX by double-clicking the software’s desktop icon or 

searching for SNAP Desktop software among your computer 

programs. The .exe file is saved in the bin folder in the snap 

folder in your directory of program files. For Mac OSX users, this 

will be in the User/Applications/snap/bin folder. 

a. Make sure that any available updates have been applied. A message will 

usually display in the bottom right corner when updates are available, but 

you can also check by selecting Check for Updates from the Help menu. 

2. Create a new folder (i.e. Sentinel_RTC_S1TBX) to contain the files for this 

recipe and move the downloaded Sentinel-1 GRD granule into this new folder. 

a. Do not unzip the GRD granule. S1TBX uses the .zip file structure and will 

not recognize the extracted .SAFE directory. 

 

D) Steps for Generating an RTC Image 

Open the GRD granule in S1TBX 

1. Open S1TBX (See Section C). 

2. From the File menu, select Open Product or click 

the Open Product icon (Figure 1). 

3. Browse to the folder that contains 

your Sentinel-1 data, and double- 

click the .zip file (or highlight the 

file and click Open). Figure 1: Open GRD Product in the S1TBX 

http://www.alaska.edu/nondiscrimination
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a. If you get an error that no appropriate product reader was found, make 

sure that all updates have been applied (Section C), restart S1TBX, and 

re-download the GRD granule; the zip file contents may have been 

corrupted. 

4. Note that as new products are generated during S1TBX processing, they will be 

displayed in the Product Explorer window numbered sequentially (in square 

brackets) in the order in which they were generated (Figure 5). 

 

Apply Radiometric Terrain Correction 

1. Apply Orbit File 

a. Highlight the GRD granule in 

the Product Explorer pane by 

clicking it once, then select 

Apply Orbit File from the 

Radar menu (Figure 2). 

i. In the I/O Parameters 

tab, set the Directory 

path to the same folder 

that contains your .zip 

file, and verify that the 

source is the correct 

granule (Figure 3). 

 
 
 

 

 
Figure 4: Apply Orbit File in Radar Menu 

 

  

ii. In the Processing Parameters tab, verify that Orbit State Vectors is 
set to Sentinel Precise (Auto Download). This will automatically find 

Figure 3: Apply Orbit File - I/O Parameters Figure 2: Apply Orbit File - Processing Parameters 
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the appropriate Orbit file from the ESA website (Figure 4).  

iii. Click Run. A Writing Target Product popup shows your progress. 

b. The output from the Apply Orbit File process now appears as the second 

product in the Product Explorer pane, with a _Orb tag on the filename and 

prefixed with [2] (Figure 5). 
 

 
Figure 5: Naming and numbering convention in the Product Explorer 

 

NOTE: Depending on the computing power of your machine, this process can take from 

less than a minute to several minutes to complete. 
 
 

 

 

2. Calibrate Data 

a. Single-click the _Orb file in the 

Product Explorer pane. 

b. In the Radar menu, select 

Radiometric > Calibrate (Figure 7). 

c. In the Calibration dialog box, verify 
that the source is the _Orb 
product, and that the directory is 
the same output folder. 

Figure 7: Selecting the Calibrate function in the 
Radiometric group of the Radar menu

NOTE: If the Writing Target 

Product popup window does 

NOT appear, the software 

may be having difficulty 

locating the orbit files, and a 

window may eventually 

display directing you to 

download the orbit file 
Figure 6: Error message when Orbit File is not found. 

manually (Figure 6). If this happens, follow the directions. Make sure to type in 

the https:// before the website address. Click on the POD Precise Orbit 

Ephemerides link and use the filters in the Validity Start section of the panel 

on the right side of the webpage to browse to an orbit file that includes the 

necessary date. You may need to add additional folders to the destination 

directory in order to match the destination path required by S1TBX. 
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d. Under the Processing Parameters tab, select Output beta0 band (the next 

step requires a beta0 output), and remove the check from any of the other 

output options (Figure 8). 

i. Your granule may have 

multiple polarizations listed, 

which is fine. 

e. Click the Run button. 

f. The output will have a _Cal tag at 

the end of the filename (product [3]). 

3. Flatten Terrain Radiometrically 

a. Single-click the _Orb_Cal product in 

the Product Explorer pane. 

b. In the Radar menu, select 

Radiometric > Radiometric Terrain 

Flattening (Figure 9). 

c. Verify that the source is the 

_Orb_Cal product, and that the 

output directory is correct. 

d. In the Processing Parameters tab, 

the Digital Elevation Model is 

already listed; it is selected 

automatically to match the 

geolocation of the GRD granule 

and downloaded from ESA. 

e. Click the Run button. This step 
may take upwards of an hour to 
complete. 

f. The output will have a _TF tag at 
the end of the filename (product 
[4]). 

 

Figure 8: Calibration Processing Parameters 

 

 
Figure 9: Radiometric Terrain function in the 

Radiometric group of the Radar menu 
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4. Apply Geometric Terrain Correction 

a. Single-click the _Orb_Cal_TF 
product in the Product Explorer 
pane. 

b. In the Radar menu, select 

Geometric > Terrain Correction > 

Range- Doppler Terrain Correction 

(Figure 10). 

Figure 10: Range-Doppler Terrain 
Correction (in the Radar menu) 

c. Verify that the source is _Orb_Cal_TF product, and that the output 

directory is correct. 

d. In the Processing Parameters tab, change the following settings 

(Figure 11): 

i. Click the button next 

to Map Projection. 

Select “UTM / WGS 

84 (Automatic)” from 

the Projection 

dropdown menu and 

click OK. The correct 

UTM zone will be 

automatically 

selected based on the 

granule location and 

displayed for the Map 

Projection. 

ii. If desired, you may 

set the pixel spacing 

to a value other than 

the source pixel 

spacing. 

iii. Note that if you had 

Figure 11: Range Doppler Terrain Correction 
Processing Parameters 

multiple polarizations in previous steps, there will be multiple 

Source Bands listed. 
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iv. Leave all remaining settings as default, unless you would like to 

output additional products, such as the DEM or incidence angle 

bands. 

e. Click the Run button. This step may take on the order of 30 minutes to 

complete. 

f. The output will have a _TC tag at the end of the filename (product [5]). 

5. View the RTC image in S1TBX 

a. Double-click the _Orb_Cal_TF_TC product in the Product Explorer pane 

to expand the product contents. 

b. Expand the Bands item. 

c. Double-click on the image file named Gamma0_VV. The image will open 

in the S1TBX interface, and you may use other tools in the interface to 

interact with the image. You may wish to explore the Tool Windows 

available in the View menu (Figure 12). 

i. The Navigation window allows you to pan and zoom. 

ii. The World View 

window shows where 

the granule is 

located on a globe- 

like view, while 

World Map shows 

the granule location 

on a flattened map of 

the world. 

iii. The Colour 

Manipulation pane 

displays the values 

contained in the 

image and includes 

tools for visualizing 

the image and data 

values. 
 

Figure 12: Tool Windows 

d. Zooming in on the mountainous regions of the radiometrically terrain 
corrected product, you may notice patches of missing data. This is a 

http://www.alaska.edu/nondiscrimination


27 March 2019 v.9.0 |8 
 | 8 

UAF is an AA/EO employer and educational institution and prohibits illegal discrimination against any individual: 
www.alaska.edu/nondiscrimination 

 
 

consequence of the Sentinel-1’s look angle and shadows created by high 
relief topography (Figure 13). 

 

 
Figure 13: Radar shadows with missing data 

6. Save the S1TBX Session 

a. Under the File menu, select Session – Save Session As. 

i. Browse to the directory where you would like to save the session 

and enter a name for the session file. 

b. Saving a session retains all of the products generated during the RTC 

process, allowing for easy viewing of the different steps, and amendments 

to the settings. This is especially useful if you are not able to finish the 

entire process in one sitting and want to save your work to continue later. 

c. To re-open a session: 

i. Under the File menu, select Session – Open Session. 

ii. Browse to your saved session and double-click to Open. 
 
 

E) OPTIONAL: View RTC Image in a GIS Program 

The TC outputs are in ENVI format, comprised of a header file (.hdr) and an image file 

(.img). To view the data in a GIS, both files must be present in the same folder. If you 

have not made any changes to the TC product folder, these files will be stored together, 

allowing the image to be added easily to either ArcGIS or QGIS. 
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ArcGIS 

1. Open ArcMap and use the Catalog window to navigate to the folder 

containing your S1TBX products (See Section C). This is located on the 

right-hand side of the window (Figure 14). 

a. Right click on “Folder Connections” and select Connect To Folder 

(Figure 15). 

 

Figure 15: Opening a folder in ArcMap 

b. Navigate to your product’s parent directory. 

2. Expand the _Orb_Cal_TF_TC.data folder and drag the Gamma0_VV.img file 

into your project. Build pyramids if desired (it will take a while). 

a. Note that only the .img file will appear in the Catalog window; the .hdr file 

is hidden from view, but used by ArcGIS to properly display the .img file. 

3. The image may appear very dark in GIS. You may change the stretch 

properties to display the image in a more visually useful way, or refer to the ASF 

Data Recipes on How to View RTC in GIS for instructions on converting the 

values from power to another scale (Amplitude or dB) for easier viewing. This 

second approach creates a new raster with a different value scale, while 

changing the stretch does not impact the actual power data values. 

a. To simply change the stretch without generating new data: 

i. Right-click on the layer in the Table of Contents, select 

Properties (Figure 16).  

ii. In the Symbology tab, under the Stretched option, set the Stretch 

Type to Standard Deviations (the default is Percent Clip). 

iii. The default value for the number of standard deviations is 2.5, 

which is fine for many RTC images. You may find that a different 

number works better for your image; try a few others and use the 

Apply button to find the value that you like best for your dataset. 

When you’ve decided on a value, click the OK button. 

Figure 14: Catalog tab 
in ArcMap 

 

http://www.alaska.edu/nondiscrimination
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iv. When using the Identify tool on a stretched 

image, the main Identify window will still 

display the original power value. The 

expanded feature properties will display 

both the Stretched value and the original 

(power) pixel value. 

 

 

 

 

 

QGIS 

Open QGIS and use the Browser panel to navigate to your data 

folder (Figure 17). 

b. If your Browser panel is not open, right-click in the open 

grey area by the toolbars and select Browser Panel 

from the dropdown list. 

2. Expand the _Orb_Cal_TF_TC.data folder and drag the 

Gamma0_VV.img file into your Layers panel. 

a. Unlike ArcGIS, the file structure is transparent, so you 

can see files in the Browser panel that are not GIS-

readable. You can see that each .img file has an 

associated .hdr file. As in ArcGIS, you only need to add 

the .img file, and it will recognize the associated .hdr file 

and use the contents appropriately to display the image.  

3. As in ArcGIS, you can adjust the appearance of the image by changing the 

Stretch settings, or refer to the ASF Data Recipes on How to View RTC in GIS 

for instructions on converting the values from power to another scale (Amplitude 

or dB) for easier viewing. This second approach creates a new raster with a 

different value scale, while changing the stretch does not impact the actual power 

data values. 

In QGIS 2.18, the default Min/Max stretch value settings defaulted to the 

“Cumulative count cut” setting, which tends to render RTC images fairly well. 

With the release of QGIS 3.0, the default settings changed so that the stretch 

Min/Max values match the actual range of data values in the image by default. 

Figure 17: Navigate to 
your folder under Home 
using the Browser panel 

 

Figure 16: Opening 
layer properties in 

ArcMap 
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This will generally result in a very dark RTC image. 

You may adjust the stretch settings in either case, but it will be more necessary 

in QGIS 3.X. 

NOTE: The symbology legend beneath the layer in the Layers panel will display 

the range of stretched values, but if you use the Identify Features tool (located 

under the View dropdown), it will only display the original power value. 

 
QGIS 2.18 

a. Right-click the Gamma0_VV layer in the Layers panel and select 

Properties. 

b. Under the Style tab, expand the “Load min/max values” section. 

i. The default in 2.18 is the Cumulative count cut option, which 

generally displays well. You can adjust the values, click the Load 

button to recalculate the min/max values, and click the Apply button 

at the bottom of the dialog box to view how the changes impact the 

image display. Click OK to finish. 

ii. Another approach is to use the Mean +/- standard deviation option. 

The default of 2 is usually okay, but in some images, you may 

want to experiment with other values. Click the Load button to 

calculate changes and use the Apply button if you’d like to test the 

settings before clicking OK to finish. 

 

QGIS 3.X 
 

a. Right-click the Gamma0_VV layer in the Layers panel and select Properties. 

b. Under the Symbology tab, expand the “Min / max values settings” section. The 

default in 3.X is Min / max, which will tend to display very dark. 

i. To use the same settings as the 2.18 default, select the Cumulative count 

cut option. The default values are probably appropriate, but you can 

change the values and use the Apply button to view the effects before 

clicking OK to close. 

ii. Another approach is to use the Mean +/- standard deviation option. The 

default of 2 is usually okay, but in some images, you may want to 

experiment with other values. Use the Apply button to view the effects 

before clicking OK to close. 
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